What’s Vulnerable › Vulnerabilities
CVE-2019-3780: Cloud Foundry Container Runtime Leaks IAAS Credentials
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-08 · updated 2026-06-17
- Weakness: CWE-260
Description
Cloud Foundry Container Runtime, versions prior to 0.28.0, deploys K8s worker nodes that contains a configuration file with IAAS credentials. A malicious user with access to the k8s nodes can obtain IAAS credentials allowing the user to escalate privileges to gain access to the IAAS account.
Affected products
- Cloud Foundry Container Runtime (CFCR): before 0.28.0 — fixed in 0.28.0
How to fix
Upgrade to a fixed version: Cloud Foundry Container Runtime (CFCR) 0.28.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107434
- https://www.cloudfoundry.org/blog/cve-2019-3780
- http://www.securityfocus.com/bid/107434
- https://www.cloudfoundry.org/blog/cve-2019-3780
Get alerted when CVE-2019-3780 or the next vulnerability affects your stack