What’s Vulnerable › Vulnerabilities
CVE-2019-3786: BBR could run arbitrary scripts on deployment VMs
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-24 · updated 2026-06-17
- Weakness: CWE-269
Description
Cloud Foundry BOSH Backup and Restore CLI, all versions prior to 1.5.0, does not check the authenticity of backup scripts in BOSH. A remote authenticated malicious user can modify the metadata file of a Bosh Backup and Restore job to request extra backup files from different jobs upon restore. The exploited hooks in this metadata script were only maintained in the cfcr-etcd-release, so clusters deployed with the BBR job for etcd in this release are vulnerable.
Affected products
- Cloud Foundry BOSH Backup and Restore: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Cloud Foundry BOSH Backup and Restore 1.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3786 or the next vulnerability affects your stack