What’s Vulnerable › Vulnerabilities
CVE-2019-3792: Concourse 5.0.0 SQL Injection vulnerability
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-01 · updated 2026-06-17
- Weakness: CWE-89
Description
Pivotal Concourse version 5.0.0, contains an API that is vulnerable to SQL injection. An Concourse resource can craft a version identifier that can carry a SQL injection payload to the Concourse server, allowing the attacker to read privileged data.
Affected products
- Pivotal Concourse: before 5.0.1 — fixed in 5.0.1
How to fix
Upgrade to a fixed version: Pivotal Concourse 5.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-3792 or the next vulnerability affects your stack