What’s Vulnerable › Vulnerabilities

CVE-2019-3795: Insecure Randomness When Using a SecureRandom Instance Constructed by Spring Security

Description

Spring Security versions 4.2.x prior to 4.2.12, 5.0.x prior to 5.0.12, and 5.1.x prior to 5.1.5 contain an insecure randomness vulnerability when using SecureRandomFactoryBean#setSeed to configure a SecureRandom instance. In order to be impacted, an honest application must provide a seed and make the resulting random material available to an attacker for inspection.

Affected products

How to fix

Upgrade to a fixed version: Spring Security 4.2.12, 5.0.12, 5.1.5; Spring Security 5.0.11.RELEASE, 5.1.4.RELEASE, 4.2.11.RELEASE. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3795 or the next vulnerability affects your stack