What’s Vulnerable › Vulnerabilities
CVE-2019-3798: Escalation of Privileges in Cloud Controller
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-17 · updated 2026-06-17
- Weakness: CWE-287
Description
Cloud Foundry Cloud Controller API Release, versions prior to 1.79.0, contains improper authentication when validating user permissions. A remote authenticated malicious user with the ability to create UAA clients and knowledge of the email of a victim in the foundation may escalate their privileges to that of the victim by creating a client with a name equal to the guid of their victim.
Affected products
- Cloud Foundry CAPI: before 1.79.0 — fixed in 1.79.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.79.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108095
- https://www.cloudfoundry.org/blog/cve-2019-3798
- http://www.securityfocus.com/bid/108095
- https://www.cloudfoundry.org/blog/cve-2019-3798
Get alerted when CVE-2019-3798 or the next vulnerability affects your stack