What’s Vulnerable › Vulnerabilities

CVE-2019-3799: Directory Traversal with spring-cloud-config-server

Description

Spring Cloud Config, versions 2.1.x prior to 2.1.2, versions 2.0.x prior to 2.0.4, and versions 1.4.x prior to 1.4.6, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead a directory traversal attack.

Affected products

How to fix

Upgrade to a fixed version: Spring Cloud Config 1.4.6, 2.0.4, 2.1.2; Spring Cloud Config v2.0.4.RELEASE, v1.4.6.RELEASE, v2.1.2.RELEASE. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3799 or the next vulnerability affects your stack