What’s Vulnerable › Vulnerabilities
CVE-2019-3806
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-29 · updated 2026-06-17
- Weakness: CWE-358
Description
An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security policies enforced using Lua.
Affected products
- PowerDNS Recursor: from 4.1.4 before 4.1.9 — fixed in 4.1.9
How to fix
Upgrade to a fixed version: PowerDNS Recursor 4.1.9. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3806
- https://docs.powerdns.com/recursor/security-advisories/powerdns-advisory-2019-01.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3806
- https://docs.powerdns.com/recursor/security-advisories/powerdns-advisory-2019-01.html
Get alerted when CVE-2019-3806 or the next vulnerability affects your stack