What’s Vulnerable › Vulnerabilities
CVE-2019-3818
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-05 · updated 2026-06-17
- Weakness: CWE-327
Description
The kube-rbac-proxy container before version 0.4.1 as used in Red Hat OpenShift Container Platform does not honor TLS configurations, allowing for use of insecure ciphers and TLS 1.0. An attacker could target traffic sent over a TLS connection with a weak configuration and potentially break the encryption.
Affected products
- Kube-Rbac-Proxy Project Kube-Rbac-Proxy: before 0.4.1 — fixed in 0.4.1
- Red Hat OpenShift Container Platform 4.18: 3.11
How to fix
Upgrade to a fixed version: Kube-Rbac-Proxy Project Kube-Rbac-Proxy 0.4.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106744
- https://access.redhat.com/errata/RHBA-2019:0327
- https://access.redhat.com/security/cve/CVE-2019-3818
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3818
- http://www.securityfocus.com/bid/106744
- https://access.redhat.com/errata/RHBA-2019:0327
- https://access.redhat.com/security/cve/CVE-2019-3818
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3818
Get alerted when CVE-2019-3818 or the next vulnerability affects your stack