What’s Vulnerable › Vulnerabilities
CVE-2019-3820
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-06 · updated 2026-06-17
- Weakness: CWE-285
Description
It was discovered that the gnome-shell lock screen since version 3.15.91 did not properly restrict all contextual actions. An attacker with physical access to a locked workstation could invoke certain keyboard shortcuts, and potentially other actions.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- gnome-shell: from 3.15.91 before 3.30.3; from 3.31.0 before 3.31.5 — fixed in 3.30.3, 3.31.5
- openSUSE Leap: 15.0, 15.1, 42.3
How to fix
Upgrade to a fixed version: gnome-shell 3.30.3, 3.31.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00049.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3820
- https://gitlab.gnome.org/GNOME/gnome-shell/issues/851
- https://usn.ubuntu.com/3966-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00049.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3820
- https://gitlab.gnome.org/GNOME/gnome-shell/issues/851
- https://usn.ubuntu.com/3966-1/
Get alerted when CVE-2019-3820 or the next vulnerability affects your stack