What’s Vulnerable › Vulnerabilities
CVE-2019-3822
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-06 · updated 2026-06-17
- Weakness: CWE-121
Description
libcurl versions from 7.36.0 to before 7.64.0 are vulnerable to a stack-based buffer overflow. The function creating an outgoing NTLM type-3 header (`lib/vauth/ntlm.c:Curl_auth_create_ntlm_type3_message()`), generates the request HTTP header contents based on previously received data. The check that exists to prevent the local buffer from getting overflowed is implemented wrongly (using unsigned math) and as such it does not prevent the overflow from happening. This output data can grow larger than the local buffer if very large 'nt response' data is extracted from a previous NTLMv2 header provided by the malicious or broken HTTP server. Such a 'large value' needs to be around 1000 bytes or more. The actual payload data copied to the target buffer comes from the NTLMv2 type-2 response header.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 9.0
- curl: from 7.36.0 before 7.64.0 — fixed in 7.64.0
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: from 7.3; from 9.5
- Clustered Data ONTAP: all versions
- OnCommand Insight: all versions
- NetApp OnCommand Workflow Automation: all versions
- NetApp SnapCenter: all versions
- Oracle Corporation Communications Operations Monitor: 3.4, 4.0
- Oracle Corporation Enterprise Manager Ops Center: 12.3.3, 12.4.0
- Oracle Corporation Oracle HTTP Server: 12.2.1.3.0
- MySQL Server: through 5.7.26; from 5.7.27 through 8.0.15
- Oracle Corporation Secure Global Desktop: 5.4
- Oracle Services Tools Bundle: 19.2
- Red Hat Enterprise Linux: 8.0
- Siemens SINEMA Remote Connect Client: through 2.0
How to fix
Upgrade to a fixed version: curl 7.64.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106950
- https://access.redhat.com/errata/RHSA-2019:3701
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3822
- https://cert-portal.siemens.com/productcert/pdf/ssa-436177.pdf
- https://curl.haxx.se/docs/CVE-2019-3822.html
- https://lists.apache.org/thread.html/8338a0f605bdbb3a6098bb76f666a95fc2b2f53f37fa1ecc89f1146f%40%3Cdevnull.infra.apache.org%3E
- https://security.gentoo.org/glsa/201903-03
- https://security.netapp.com/advisory/ntap-20190315-0001/
- https://security.netapp.com/advisory/ntap-20190719-0004/
- https://support.f5.com/csp/article/K84141449
- https://support.f5.com/csp/article/K84141449?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/3882-1/
Get alerted when CVE-2019-3822 or the next vulnerability affects your stack