What’s Vulnerable › Vulnerabilities
CVE-2019-3824
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-06 · updated 2026-06-17
- Weakness: CWE-125
Description
A flaw was found in the way an LDAP search expression could crash the shared LDAP server process of a samba AD DC in samba before version 4.10. An authenticated user, having read permissions on the LDAP server, could use this flaw to cause denial of service.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0
- Samba: before 4.10.0 — fixed in 4.10.0
How to fix
Upgrade to a fixed version: Samba 4.10.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00035.html
- http://www.securityfocus.com/bid/107347
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3824
- https://bugzilla.samba.org/show_bug.cgi?id=13773
- https://lists.debian.org/debian-lts-announce/2019/03/msg00000.html
- https://security.netapp.com/advisory/ntap-20190226-0001/
- https://usn.ubuntu.com/3895-1/
- https://www.debian.org/security/2019/dsa-4397
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00035.html
- http://www.securityfocus.com/bid/107347
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3824
- https://bugzilla.samba.org/show_bug.cgi?id=13773
Get alerted when CVE-2019-3824 or the next vulnerability affects your stack