What’s Vulnerable › Vulnerabilities
CVE-2019-3827
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-863
Description
An incorrect permission check in the admin backend in gvfs before version 1.39.4 was found that allows reading and modify arbitrary files by privileged users without asking for password when no authentication agent is running. This vulnerability can be exploited by malicious programs running under privileges of users belonging to the wheel group to further escalate its privileges by modifying system files without user's knowledge. Successful exploitation requires uncommon system configuration.
Affected products
- GNOME gvfs: before 1.39.4 — fixed in 1.39.4
How to fix
Upgrade to a fixed version: GNOME gvfs 1.39.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:1517
- https://access.redhat.com/errata/RHSA-2019:2145
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3827
- https://gitlab.gnome.org/GNOME/gvfs/merge_requests/31
- https://access.redhat.com/errata/RHSA-2019:1517
- https://access.redhat.com/errata/RHSA-2019:2145
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3827
- https://gitlab.gnome.org/GNOME/gvfs/merge_requests/31
Get alerted when CVE-2019-3827 or the next vulnerability affects your stack