What’s Vulnerable › Vulnerabilities

CVE-2019-3828

Description

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Affected products

How to fix

Upgrade to a fixed version: Red Hat Ansible 2.5.15, 2.6.14, 2.7.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3828 or the next vulnerability affects your stack