What’s Vulnerable › Vulnerabilities
CVE-2019-3829
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 59.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-27 · updated 2026-06-17
- Weakness: CWE-416
Description
A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.
Affected products
- Fedoraproject Fedora: all versions
- [UNKNOWN] gnutls: from 3.5.8 before 3.6.7 — fixed in 3.6.7
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.6.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00017.html
- https://access.redhat.com/errata/RHSA-2019:3600
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3829
- https://gitlab.com/gnutls/gnutls/issues/694
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/A3ETBUFBB4G7AITAOUYPGXVMBGVXKUAN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L7TJIBRJWGWSH6XIO2MXIQ3W6ES4R6I4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WRSOL66LHP4SD3Y2ECJDOGT4K663ECDU/
- https://security.gentoo.org/glsa/201904-14
- https://security.netapp.com/advisory/ntap-20190619-0004/
- https://usn.ubuntu.com/3999-1/
- https://www.gnutls.org/security-new.html#GNUTLS-SA-2019-03-27
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00017.html
Get alerted when CVE-2019-3829 or the next vulnerability affects your stack