What’s Vulnerable › Vulnerabilities
CVE-2019-3836
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-01 · updated 2026-06-17
- Weakness: CWE-456
Description
It was discovered in gnutls before version 3.6.7 upstream that there is an uninitialized pointer access in gnutls versions 3.6.3 or later which can be triggered by certain post-handshake messages.
Affected products
- Fedoraproject Fedora: 28
- [UNKNOWN] gnutls: from 3.6.3 before 3.6.7 — fixed in 3.6.7
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.6.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00017.html
- https://access.redhat.com/errata/RHSA-2019:3600
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3836
- https://gitlab.com/gnutls/gnutls/issues/704
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/A3ETBUFBB4G7AITAOUYPGXVMBGVXKUAN/
- https://security.gentoo.org/glsa/201904-14
- https://security.netapp.com/advisory/ntap-20190502-0005/
- https://usn.ubuntu.com/3999-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00017.html
- https://access.redhat.com/errata/RHSA-2019:3600
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3836
- https://gitlab.com/gnutls/gnutls/issues/704
Get alerted when CVE-2019-3836 or the next vulnerability affects your stack