What’s Vulnerable › Vulnerabilities
CVE-2019-3839
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-16 · updated 2026-06-17
- Weakness: CWE-648
Description
It was found that in ghostscript some privileged operators remained accessible from various places after the CVE-2019-6116 fix. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER. Ghostscript versions before 9.27 are vulnerable.
Affected products
- Artifex Ghostscript: before 9.27 — fixed in 9.27
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10, 19.04
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 29, 30
- openSUSE Leap: 15.0, 15.1
- Red Hat Enterprise Linux: 5.0, 6.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.27. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=4ec9ca74bed49f2a82acb4bf430eae0d8b3b75c9
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00088.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00090.html
- https://access.redhat.com/errata/RHSA-2019:0971
- https://access.redhat.com/errata/RHSA-2019:1017
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3839
- https://lists.debian.org/debian-lts-announce/2019/05/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6AATIHU32MYKUOXQDJQU4X4DDVL7NAY3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZP34D27RKYV2POJ3NJLSVCHUA5V5C45A/
- https://seclists.org/bugtraq/2019/May/23
- https://usn.ubuntu.com/3970-1/
- https://www.debian.org/security/2019/dsa-4442
Get alerted when CVE-2019-3839 or the next vulnerability affects your stack