What’s Vulnerable › Vulnerabilities
CVE-2019-3840
- Severity: medium (CVSS 6.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-27 · updated 2026-06-17
- Weakness: CWE-476
Description
A NULL pointer dereference flaw was discovered in libvirt before version 5.0.0 in the way it gets interface information through the QEMU agent. An attacker in a guest VM can use this flaw to crash libvirtd and cause a denial of service.
Affected products
- openSUSE Leap: 15.0, 42.3
- libvirt: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: libvirt 5.0.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00101.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00105.html
- https://access.redhat.com/errata/RHSA-2019:2294
- https://bugzilla.redhat.com/show_bug.cgi?id=1663051
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3840
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TZRP2BRMI4RYFRPNFTTIAAUOGVN2ORP7/
- https://www.redhat.com/archives/libvir-list/2019-January/msg00241.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00101.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00105.html
- https://access.redhat.com/errata/RHSA-2019:2294
- https://bugzilla.redhat.com/show_bug.cgi?id=1663051
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3840
Get alerted when CVE-2019-3840 or the next vulnerability affects your stack