What’s Vulnerable › Vulnerabilities
CVE-2019-3847
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Users with the "login as other users" capability (such as administrators/managers) can access other users' Dashboards, but the JavaScript those other users may have added to their Dashboard was not being escaped when being viewed by the user logging in on their behalf.
Affected products
- Moodle: before 3.1.17; from 3.4.0 before 3.4.8; from 3.5.0 before 3.5.5; from 3.6.0 before 3.6.3 — fixed in 3.1.17, 3.4.8, 3.5.5, 3.6.3
How to fix
Upgrade to a fixed version: Moodle 3.1.17, 3.4.8, 3.5.5, 3.6.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107489
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3847
- https://moodle.org/mod/forum/discuss.php?d=384010#p1547742
- http://www.securityfocus.com/bid/107489
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3847
- https://moodle.org/mod/forum/discuss.php?d=384010#p1547742
Get alerted when CVE-2019-3847 or the next vulnerability affects your stack