What’s Vulnerable › Vulnerabilities

CVE-2019-3848

Description

A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.4.8, 3.5.5, 3.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-3848 or the next vulnerability affects your stack