What’s Vulnerable › Vulnerabilities
CVE-2019-3849
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-26 · updated 2026-06-17
- Weakness: CWE-285
Description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
Affected products
- Moodle: before 3.4.8; from 3.5.0 before 3.5.5; from 3.6.0 before 3.6.3 — fixed in 3.4.8, 3.5.5, 3.6.3
How to fix
Upgrade to a fixed version: Moodle 3.4.8, 3.5.5, 3.6.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3849
- https://moodle.org/mod/forum/discuss.php?d=384012#p1547744
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3849
- https://moodle.org/mod/forum/discuss.php?d=384012#p1547744
Get alerted when CVE-2019-3849 or the next vulnerability affects your stack