What’s Vulnerable › Vulnerabilities
CVE-2019-3852
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-26 · updated 2026-06-17
Description
A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities
Affected products
- Moodle: before 3.6.3 — fixed in 3.6.3
How to fix
Upgrade to a fixed version: Moodle 3.6.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3852
- https://moodle.org/mod/forum/discuss.php?d=384015#p1547748
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3852
- https://moodle.org/mod/forum/discuss.php?d=384015#p1547748
Get alerted when CVE-2019-3852 or the next vulnerability affects your stack