What’s Vulnerable › Vulnerabilities
CVE-2019-3855
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-10-14
- Weakness: CWE-190
Description
An integer overflow flaw which could lead to an out of bounds write was discovered in libssh2 before 1.8.1 in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to execute code on the client system when a user connects to the server.
Affected products
- Apple Xcode: before 11.0 — fixed in 11.0
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 28, 29, 30
- libssh2: before 1.8.1 — fixed in 1.8.1
- NetApp ONTAP Select Deploy administration utility: all versions
- openSUSE Leap: 42.3
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.56, 8.57
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Apple Xcode 11.0; libssh2 1.8.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-03/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00003.html
- http://packetstormsecurity.com/files/152136/Slackware-Security-Advisory-libssh2-Updates.html
- http://seclists.org/fulldisclosure/2019/Sep/42
- http://www.openwall.com/lists/oss-security/2019/03/18/3
- http://www.securityfocus.com/bid/107485
- https://access.redhat.com/errata/RHSA-2019:0679
- https://access.redhat.com/errata/RHSA-2019:1175
- https://access.redhat.com/errata/RHSA-2019:1652
- https://access.redhat.com/errata/RHSA-2019:1791
- https://access.redhat.com/errata/RHSA-2019:1943
- https://access.redhat.com/errata/RHSA-2019:2399
Get alerted when CVE-2019-3855 or the next vulnerability affects your stack