What’s Vulnerable › Vulnerabilities
CVE-2019-3869
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-28 · updated 2026-06-17
- Weakness: CWE-214
Description
When running Tower before 3.4.3 on OpenShift or Kubernetes, application credentials are exposed to playbook job runs via environment variables. A malicious user with the ability to write playbooks could use this to gain administrative privileges.
Affected products
- Tower: before 3.3.5; from 3.4.0 before 3.4.3 — fixed in 3.3.5, 3.4.3
How to fix
Upgrade to a fixed version: Tower 3.3.5, 3.4.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3869
- https://github.com/ansible/awx/pull/3505
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3869
- https://github.com/ansible/awx/pull/3505
Get alerted when CVE-2019-3869 or the next vulnerability affects your stack