What’s Vulnerable › Vulnerabilities
CVE-2019-3878
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-26 · updated 2026-06-17
- Weakness: CWE-305
Description
A vulnerability was found in mod_auth_mellon before v0.14.2. If Apache is configured as a reverse proxy and mod_auth_mellon is configured to only let through authenticated users (with the require valid-user directive), adding special HTTP headers that are normally used to start the special SAML ECP (non-browser based) can be used to bypass authentication.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- Fedoraproject Fedora: 29, 30
- Mod Auth Mellon Project Mod Auth Mellon: before 0.14.2 — fixed in 0.14.2
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Mod Auth Mellon Project Mod Auth Mellon 0.14.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2019:0959
- https://access.redhat.com/errata/RHSA-2019:0746
- https://access.redhat.com/errata/RHSA-2019:0766
- https://access.redhat.com/errata/RHSA-2019:0985
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3878
- https://github.com/Uninett/mod_auth_mellon/pull/196
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CNW5YMC5TLWVWNJEY6AIWNSNPRAMWPQJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X7NLAU7KROWNTHAYSA2S67X347F42L2I/
- https://usn.ubuntu.com/3924-1/
- https://access.redhat.com/errata/RHBA-2019:0959
- https://access.redhat.com/errata/RHSA-2019:0746
- https://access.redhat.com/errata/RHSA-2019:0766
Get alerted when CVE-2019-3878 or the next vulnerability affects your stack