What’s Vulnerable › Vulnerabilities
CVE-2019-3881
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-04 · updated 2026-06-17
- Weakness: CWE-427
Description
Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.
Affected products
- rubygem-bundler: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: rubygem-bundler 2.1.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1651826
- https://bugzilla.redhat.com/show_bug.cgi?id=1651826
Get alerted when CVE-2019-3881 or the next vulnerability affects your stack