What’s Vulnerable › Vulnerabilities
CVE-2019-3886
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-04 · updated 2026-06-17
- Weakness: CWE-862
Description
An incorrect permissions check was discovered in libvirt 4.8.0 and above. The readonly permission was allowed to invoke APIs depending on the guest agent, which could lead to potentially disclosing unintended information or denial of service by causing libvirt to block.
Affected products
- Fedoraproject Fedora: 29, 30
- openSUSE Leap: 42.3
- libvirt: from 4.8.0 before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: libvirt 5.3.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00105.html
- http://www.securityfocus.com/bid/107777
- https://access.redhat.com/errata/RHBA-2019:3723
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3886
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CYMNKXAUBZCFBBPFH64FJPH5EJH4GSU2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R5DHYIFECZ7BMVXK4EP4FDFZXK7I5MZH/
- https://usn.ubuntu.com/4021-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00105.html
- http://www.securityfocus.com/bid/107777
- https://access.redhat.com/errata/RHBA-2019:3723
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3886
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CYMNKXAUBZCFBBPFH64FJPH5EJH4GSU2/
Get alerted when CVE-2019-3886 or the next vulnerability affects your stack