What’s Vulnerable › Vulnerabilities
CVE-2019-3890
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-295
Description
It was discovered evolution-ews before 3.31.3 does not check the validity of SSL certificates. An attacker could abuse this flaw to get confidential information by tricking the user into connecting to a fake server without the user noticing the difference.
Affected products
- GNOME Evolution-Ews: before 3.31.3 — fixed in 3.31.3
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: GNOME Evolution-Ews 3.31.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:3699
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3890
- https://gitlab.gnome.org/GNOME/evolution-ews/issues/27
- https://access.redhat.com/errata/RHSA-2019:3699
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3890
- https://gitlab.gnome.org/GNOME/evolution-ews/issues/27
Get alerted when CVE-2019-3890 or the next vulnerability affects your stack