What’s Vulnerable › Vulnerabilities
CVE-2019-4046
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-400
Description
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 is vulnerable to a denial of service, caused by improper handling of request headers. A remote attacker could exploit this vulnerability to cause the consumption of Memory. IBM X-Force ID: 156242.
Affected products
- IBM WebSphere Application Server: before 19.0.0.4; from 7.0.0.0 through 7.0.0.45; from 8.0.0.0 through 8.0.0.15; from 8.5.0.0 through 8.5.5.15; from 9.0.0.0 through 9.0.0.10 — fixed in 19.0.0.4
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 19.0.0.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107623
- https://exchange.xforce.ibmcloud.com/vulnerabilities/156242
- https://www.ibm.com/support/docview.wss?uid=ibm10869570
- http://www.securityfocus.com/bid/107623
- https://exchange.xforce.ibmcloud.com/vulnerabilities/156242
- https://www.ibm.com/support/docview.wss?uid=ibm10869570
Get alerted when CVE-2019-4046 or the next vulnerability affects your stack