What’s Vulnerable › Vulnerabilities
CVE-2019-4294
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-20 · updated 2026-06-17
- Weakness: CWE-78
Description
IBM DataPower Gateway 2018.4.1.0 through 2018.4.1.6, 7.6.0.0 through 7.6.0.15 and IBM MQ Appliance 8.0.0.0 through 8.0.0.12, 9.1.0.0 through 9.1.0.2, and 9.1.1 through 9.1.2 could allow a local attacker to execute arbitrary commands on the system, caused by a command injection vulnerability. IBM X-Force ID: 16188.
Affected products
- IBM DataPower Gateway 11.0.0: before 2018.4.1.7; from 7.6.0.0 through 7.6.0.15; from 2018.4.1.0 through 2018.4.1.6 — fixed in 2018.4.1.7
- IBM MQ Appliance: from 8.0.0.0 through 8.0.0.12; from 9.1.0.0 through 9.1.0.2; from 9.1.1 through 9.1.2
How to fix
Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 2018.4.1.7. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/160701
- https://www.ibm.com/support/docview.wss?uid=ibm10887005
- https://www.ibm.com/support/docview.wss?uid=ibm10958933
- https://exchange.xforce.ibmcloud.com/vulnerabilities/160701
- https://www.ibm.com/support/docview.wss?uid=ibm10887005
- https://www.ibm.com/support/docview.wss?uid=ibm10958933
Get alerted when CVE-2019-4294 or the next vulnerability affects your stack