What’s Vulnerable › Vulnerabilities
CVE-2019-4304
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-30 · updated 2026-06-17
- Weakness: CWE-384
Description
IBM WebSphere Application Server - Liberty could allow a remote attacker to bypass security restrictions caused by improper session validation. IBM X-Force ID: 160950.
Affected products
- IBM WebSphere Application Server: before 19.0.0.10 — fixed in 19.0.0.10
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 19.0.0.10. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/160950
- https://www.ibm.com/support/pages/node/960171
- https://exchange.xforce.ibmcloud.com/vulnerabilities/160950
- https://www.ibm.com/support/pages/node/960171
Get alerted when CVE-2019-4304 or the next vulnerability affects your stack