What’s Vulnerable › Vulnerabilities
CVE-2019-4409
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
HCL Traveler versions 9.x and earlier are susceptible to cross-site scripting attacks. On the Problem Report page of the Traveler servlet pages, there is a field to specify a file attachment to provide additional problem details. An invalid file name returns an error message that includes the entered file name. If the file name is not escaped in the returned error page, it could expose a cross-site scripting (XSS) vulnerability.
Affected products
- HCL Software HCL Traveler: before 10.0.0.0 — fixed in 10.0.0.0
How to fix
Upgrade to a fixed version: HCL Software HCL Traveler 10.0.0.0. Check the vendor advisory for mitigations.
References
- https://hclpnpsupport.hcltech.com/csm?id=kb_article&sysparm_article=KB0073231
- https://hclpnpsupport.hcltech.com/csm?id=kb_article&sysparm_article=KB0073231
Get alerted when CVE-2019-4409 or the next vulnerability affects your stack