What’s Vulnerable › Vulnerabilities
CVE-2019-4560
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-16 · updated 2026-06-17
Description
IBM MQ and IBM MQ Appliance 9.1 CD, 9.1 LTS, 9.0 LTS, and 8.0 is vulnerable to a denial of service attack caused by channels processing poorly formatted messages. IBM X-Force ID: 166357.
Affected products
- IBM MQ Appliance: from 8.0.0.0 before 8.0.0.13; from 9.0.0.0 before 9.0.0.8; from 9.1.0.0 before 9.1.0.4; from 9.1.1 before 9.1.4 — fixed in 8.0.0.13, 9.0.0.8, 9.1.0.4, 9.1.4
How to fix
Upgrade to a fixed version: IBM MQ Appliance 8.0.0.13, 9.0.0.8, 9.1.0.4, 9.1.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/166357
- https://www.ibm.com/support/pages/node/1106037
- https://exchange.xforce.ibmcloud.com/vulnerabilities/166357
- https://www.ibm.com/support/pages/node/1106037
Get alerted when CVE-2019-4560 or the next vulnerability affects your stack