What’s Vulnerable › Vulnerabilities
CVE-2019-4614
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
Description
IBM MQ and IBM MQ Appliance 8.0 and 9.0 LTS client connecting to a Queue Manager could cause a SIGSEGV denial of service caused by converting an invalid message. IBM X-Force ID: 168639.
Affected products
- IBM MQ: from 8.0.0.0 before 8.0.0.14; from 9.0.0.0 before 9.0.0.8; from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.0.0.8, 9.1.0.4, 9.1.4
- IBM MQ Appliance: from 8.0.0.0 before 8.0.0.14; from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.1.0.4, 9.1.4
How to fix
Upgrade to a fixed version: IBM MQ 8.0.0.14, 9.0.0.8, 9.1.0.4, 9.1.4; IBM MQ Appliance 8.0.0.14, 9.1.0.4, 9.1.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/168639
- https://www.ibm.com/support/pages/node/1106523
- https://exchange.xforce.ibmcloud.com/vulnerabilities/168639
- https://www.ibm.com/support/pages/node/1106523
Get alerted when CVE-2019-4614 or the next vulnerability affects your stack