What’s Vulnerable › Vulnerabilities
CVE-2019-4620
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM MQ Appliance 8.0 and 9.0 LTS could allow a local attacker to bypass security restrictions caused by improper validation of environment variables. IBM X-Force ID: 168863.
Affected products
- IBM MQ Appliance: from 8.0.0.0 before 8.0.0.14; from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.1.0.4, 9.1.4
How to fix
Upgrade to a fixed version: IBM MQ Appliance 8.0.0.14, 9.1.0.4, 9.1.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/168863
- https://www.ibm.com/support/pages/node/1125891
- https://exchange.xforce.ibmcloud.com/vulnerabilities/168863
- https://www.ibm.com/support/pages/node/1125891
Get alerted when CVE-2019-4620 or the next vulnerability affects your stack