What’s Vulnerable › Vulnerabilities
CVE-2019-4654
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-15 · updated 2026-06-17
- Weakness: CWE-295
Description
IBM QRadar 7.3.0 to 7.3.3 Patch 2 does not validate, or incorrectly validates, a certificate which could allow an attacker to spoof a trusted entity by using a man-in-the-middle (MITM) attack. IBM X-ForceID: 170965.
Affected products
- IBM QRadar SIEM: from 7.3.0 before 7.3.3; 7.3.3, 7.3.3-p1, 7.3.3-p2 — fixed in 7.3.3
How to fix
Upgrade to a fixed version: IBM QRadar SIEM 7.3.3. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/170965
- https://www.ibm.com/support/pages/node/6189723
- https://exchange.xforce.ibmcloud.com/vulnerabilities/170965
- https://www.ibm.com/support/pages/node/6189723
Get alerted when CVE-2019-4654 or the next vulnerability affects your stack