What’s Vulnerable › Vulnerabilities
CVE-2019-4655
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-30 · updated 2026-06-17
Description
IBM MQ 9.1.0.0, 9.1.0.1, 9.1.0.2, 9.1.0.3, 9.1.1, 9.1.2, and 9.1.3 is vulnerable to a denial of service attack that would allow an authenticated user to reset client connections due to an error within the Data Conversion routine. IBM X-Force ID: 170966.
Affected products
- IBM MQ: from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 9.1.0.4, 9.1.4
- IBM MQ Appliance: from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 9.1.0.4, 9.1.4
How to fix
Upgrade to a fixed version: IBM MQ 9.1.0.4, 9.1.4; IBM MQ Appliance 9.1.0.4, 9.1.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/170966
- https://www.ibm.com/support/pages/node/1106529
- https://exchange.xforce.ibmcloud.com/vulnerabilities/170966
- https://www.ibm.com/support/pages/node/1106529
Get alerted when CVE-2019-4655 or the next vulnerability affects your stack