What’s Vulnerable › Vulnerabilities
CVE-2019-4656
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-16 · updated 2026-06-17
Description
IBM MQ and IBM MQ Appliance 7.1, 7.5, 8.0, 9.0 LTS, 9.1 LTS, and 9.1 CD is vulnerable to a denial of service attack that would allow an authenticated user to crash the queue and require a restart due to an error processing error messages. IBM X-Force ID: 170967.
Affected products
- IBM MQ: from 8.0.0.0 before 8.0.0.14; from 9.0.0.0 through 9.0.0.9; from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.1.0.4, 9.1.4
- IBM MQ Appliance: from 8.0.0.0 before 8.0.0.14 — fixed in 8.0.0.14
- IBM Corporation WebSphere MQ: from 7.1.0.0 through 7.5.0.9
How to fix
Upgrade to a fixed version: IBM MQ 8.0.0.14, 9.1.0.4, 9.1.4; IBM MQ Appliance 8.0.0.14. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/170967
- https://www.ibm.com/support/pages/node/1135095
- https://exchange.xforce.ibmcloud.com/vulnerabilities/170967
- https://www.ibm.com/support/pages/node/1135095
Get alerted when CVE-2019-4656 or the next vulnerability affects your stack