What’s Vulnerable › Vulnerabilities
CVE-2019-4663
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM WebSphere Application Server - Liberty is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 171245.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 19.0.0.11 — fixed in 19.0.0.11
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 19.0.0.11. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/171245
- https://www.ibm.com/support/pages/node/1127367
- https://exchange.xforce.ibmcloud.com/vulnerabilities/171245
- https://www.ibm.com/support/pages/node/1127367
Get alerted when CVE-2019-4663 or the next vulnerability affects your stack