What’s Vulnerable › Vulnerabilities
CVE-2019-4691
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-26 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Security Guardium Data Encryption (GDE) 3.0.0.2 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 171828.
Affected products
- IBM Security Guardium Data Encryption: before 4.0.0.3 — fixed in 4.0.0.3
- IBM Guardium For Cloud Key Management: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: IBM Security Guardium Data Encryption 4.0.0.3; IBM Guardium For Cloud Key Management 1.7.0. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/171828
- https://www.ibm.com/support/pages/node/6320835
- https://exchange.xforce.ibmcloud.com/vulnerabilities/171828
- https://www.ibm.com/support/pages/node/6320835
Get alerted when CVE-2019-4691 or the next vulnerability affects your stack