What’s Vulnerable › Vulnerabilities
CVE-2019-4719
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-16 · updated 2026-06-17
Description
IBM MQ and IBM MQ Appliance 7.1, 7.5, 8.0, 9.0 LTS, 9.1 LTS, and 9.1 CD could allow a local attacker to obtain sensitive information by inclusion of sensitive data within runmqras data.
Affected products
- IBM MQ: from 8.0.0.0 before 8.0.0.14; from 9.0.0.0 through 9.0.0.9; from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.1.0.4, 9.1.4
- IBM MQ Appliance: from 8.0.0.0 before 8.0.0.14; from 9.1.0 before 9.1.4; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.1.0.4, 9.1.4
- IBM Corporation WebSphere MQ: from 7.1.0.0 through 7.5.0.9
How to fix
Upgrade to a fixed version: IBM MQ 8.0.0.14, 9.1.0.4, 9.1.4; IBM MQ Appliance 8.0.0.14, 9.1.0.4, 9.1.4. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/172124
- https://www.ibm.com/support/pages/node/1136608
- https://exchange.xforce.ibmcloud.com/vulnerabilities/172124
- https://www.ibm.com/support/pages/node/1136608
Get alerted when CVE-2019-4719 or the next vulnerability affects your stack