What’s Vulnerable › Vulnerabilities
CVE-2019-4720
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-31 · updated 2026-06-17
- Weakness: CWE-770
Description
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 is vulnerable to a denial of service, caused by sending a specially-crafted request. A remote attacker could exploit this vulnerability to cause the server to consume all available memory. IBM X-Force ID: 172125.
Affected products
- IBM WebSphere Application Server: before 20.0.0.2; from 7.0.0.0 through 7.0.0.45; from 8.0.0.0 through 8.0.0.15; from 8.5.0.0 through 8.5.5.17; from 9.0.0.0 through 9.0.5.2 — fixed in 20.0.0.2
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 20.0.0.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/172125
- https://www.ibm.com/support/pages/node/1285372
- https://exchange.xforce.ibmcloud.com/vulnerabilities/172125
- https://www.ibm.com/support/pages/node/1285372
Get alerted when CVE-2019-4720 or the next vulnerability affects your stack