What’s Vulnerable › Vulnerabilities
CVE-2019-5005
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-03 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in Foxit Reader and PhantomPDF before 9.4 on Windows. They allowed Denial of Service (application crash) via image data, because two bytes are written to the end of the allocated memory without judging whether this will cause corruption.
Affected products
- Foxit Reader: before 9.4 — fixed in 9.4
- Foxit PhantomPDF: before 9.4 — fixed in 9.4
How to fix
Upgrade to a fixed version: Foxit Reader 9.4; Foxit PhantomPDF 9.4. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2019-5005 or the next vulnerability affects your stack