What’s Vulnerable › Vulnerabilities

CVE-2019-5064

Description

An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, before version 4.2.0. A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.

Affected products

How to fix

Upgrade to a fixed version: OpenCV 3.0.0 4.2.0; Oracle Big Data Spatial And Graph 2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-5064 or the next vulnerability affects your stack