What’s Vulnerable › Vulnerabilities
CVE-2019-5315
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-13 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability is present in the web management interface of ArubaOS that permits an authenticated user to execute arbitrary commands on the underlying operating system. A malicious administrator could use this ability to install backdoors or change system configuration in a way that would not be logged. This vulnerability only affects ArubaOS 8.x.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 8.0.0.0 before 8.3.0.0 — fixed in 8.3.0.0
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 8.3.0.0. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2019-004.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2019-004.txt
Get alerted when CVE-2019-5315 or the next vulnerability affects your stack