What’s Vulnerable › Vulnerabilities
CVE-2019-5319
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-30 · updated 2026-06-17
- Weakness: CWE-120
Description
A remote buffer overflow vulnerability was discovered in some Aruba Instant Access Point (IAP) products in version(s): Aruba Instant 6.4.x: 6.4.4.8-4.2.4.17 and below; Aruba Instant 6.5.x: 6.5.4.16 and below; Aruba Instant 8.3.x: 8.3.0.12 and below; Aruba Instant 8.5.x: 8.5.0.6 and below; Aruba Instant 8.6.x: 8.6.0.2 and below. Aruba has released patches for Aruba Instant that address this security vulnerability.
Affected products
- Arubanetworks Instant: from 6.4.0.0 through 6.4.4.8-4.2.4.17; from 6.5.0.0 before 6.5.4.17; from 8.3.0.0 before 8.3.0.13; from 8.5.0.0 before 8.5.0.7; from 8.6.0.0 before 8.6.0.3 — fixed in 6.5.4.17, 8.3.0.13, 8.5.0.7, 8.6.0.3
- Siemens Scalance W1750D Firmware: before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: Arubanetworks Instant 6.5.4.17, 8.3.0.13, 8.5.0.7, 8.6.0.3; Siemens Scalance W1750D Firmware 8.7.0. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-723417.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-007.txt
- https://cert-portal.siemens.com/productcert/pdf/ssa-723417.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2021-007.txt
Get alerted when CVE-2019-5319 or the next vulnerability affects your stack