What’s Vulnerable › Vulnerabilities
CVE-2019-5413
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-94
Description
An attacker can use the format parameter to inject arbitrary commands in the npm package morgan < 1.9.1.
Affected products
- morgan: before 1.9.1 — fixed in 1.9.1
How to fix
Upgrade to a fixed version: morgan 1.9.1. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/390881
- https://lists.apache.org/thread.html/r8ba4c628fba7181af58817d452119481adce4ba92e889c643e4c7dd3%40%3Ccommits.netbeans.apache.org%3E
- https://lists.apache.org/thread.html/rb5ac16fad337d1f3bb7079549f97d8166d0ef3082629417c39f12d63%40%3Cnotifications.netbeans.apache.org%3E
- https://hackerone.com/reports/390881
- https://lists.apache.org/thread.html/r8ba4c628fba7181af58817d452119481adce4ba92e889c643e4c7dd3%40%3Ccommits.netbeans.apache.org%3E
- https://lists.apache.org/thread.html/rb5ac16fad337d1f3bb7079549f97d8166d0ef3082629417c39f12d63%40%3Cnotifications.netbeans.apache.org%3E
Get alerted when CVE-2019-5413 or the next vulnerability affects your stack