What’s Vulnerable › Vulnerabilities
CVE-2019-5414
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-77
Description
If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.
Affected products
- kill-port: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: kill-port 1.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-5414 or the next vulnerability affects your stack