What’s Vulnerable › Vulnerabilities
CVE-2019-5417
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-22
Description
A path traversal vulnerability in serve npm package version 7.0.1 allows the attackers to read content of arbitrary files on the remote server.
Affected products
- serve: from 7.0.1 before 7.3.1 — fixed in 7.3.1
How to fix
Upgrade to a fixed version: serve 7.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-5417 or the next vulnerability affects your stack