What’s Vulnerable › Vulnerabilities

CVE-2019-5418: Rails Ruby on Rails Path Traversal Vulnerability

Description

There is a File Content Disclosure vulnerability in Action View <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 and v3 where specially crafted accept headers can cause contents of arbitrary files on the target system's filesystem to be exposed.

Affected products

How to fix

Upgrade to a fixed version: Ruby on Rails 4.2.11.1, 5.0.7.2, 5.1.6.2, 5.2.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-5418 or the next vulnerability affects your stack