What’s Vulnerable › Vulnerabilities
CVE-2019-5421
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-03 · updated 2026-06-17
- Weakness: CWE-367
Description
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Affected products
- Plataformatec Devise ruby gem: through 4.5.0
References
- https://github.com/plataformatec/devise/issues/4981
- https://github.com/plataformatec/devise/pull/4996
- https://github.com/plataformatec/devise/issues/4981
- https://github.com/plataformatec/devise/pull/4996
Get alerted when CVE-2019-5421 or the next vulnerability affects your stack